Back
Resolved
Resolved
https://barakahdigital.com.my/ is down
Started 28 Oct at 08:15am GMT+8, resolved 29 Oct at 10:25pm GMT+8.
https://barakahdigital.com.my/
Resolved
Started 28 Oct at 08:15am GMT+8, resolved 29 Oct at 10:25pm GMT+8.