Back
Resolved
Resolved
https://barakahdigital.com.my/ is down
Started 16 Oct at 11:53pm GMT+8, resolved 16 Oct at 11:59pm GMT+8.
https://barakahdigital.com.my/
Resolved
Started 16 Oct at 11:53pm GMT+8, resolved 16 Oct at 11:59pm GMT+8.